Remotedesktop beschleunigen

  • Ich bin unter der Woche regelmässig aushäusig und hab mich immer von meinem dienstlichen Notebook per Remotedesktopverbindung (Windows-Windows) mit dem Orgel-PC verbunden. Da konnte ich dann munter Tonsätze im Capella schreiben; mit zwei einigermassen flotten Internetverbindungen (VDSL50 und 16Mbit) ging das, einschliesslich Tonausgaben, echt gut von der Hand.


    Seit einem Jahr routet mein Arbeitgeber sämtlichen Internetverkehr über die Firma und damit funktioniert das so leider nicht mehr. Ich habe mir dann einen Raspberry zugelegt und verbinde mich per rdesktop mit der Heimat. Dummerweise wurde die Sache damit elend langsam. Tastatur und Maus haken immer wieder und die Tonausgabe kommt zwei Sekunden verzögert und abgehackt. Im lokalen Netz hat die Sache einigermassen funktioniert.


    Ich frage mich, ob das am Raspberry oder am rdesktop oder nur an irgendwelchen Einstellungen liegt??
    Vielleicht hat einer der Experten einen Tip für mich?
    (Sorry falls hier OT bitte verschieben)

  • Verstehe ich es jetzt richtig dass du zusätzlich ein Raspberry mitnimmst und auf diese eine RDP Verbindung zum Heimrechner erstellst? Oder ist der Raspberry auch Zuhause?

  • Genau so. Ich habe den Raspberry in meiner Zweitwohnung, wo auch ein Monitor und die ganze Peripherie vorhanden ist.


    Ich hatte ihn nur mal vorher testweise zu Hause ins LAN gehangen und da traten diese Probleme nicht so extrem auf. Von daher vermute ich, dass es weniger am Raspberry allgemein liegt sondern eher am rdesktop (mit meinen Einstellungen?) mehr Bandbreite benötigt als die Windows-Tools.

  • Quote

    da traten diese Probleme nicht so extrem auf.


    Im lokalen LAN sollte der Remote Desktop eigentlich komplett verzögerungs/störungsfrei funktionieren (auch mit rdesktop - wobei ich Sound forwarding noch nie genutzt habe).

  • Probier doch mal in der RDP Einstellungen/Leistung auf deiner Raspberry die Übertragungsrate selber anzugeben. Vielleicht kann er die Verbindung nicht richtig erkennen und hilft es wenn du ihm sagst dass der Leitung jetzt nicht so schnell ist damit es auch entsprechend optimiert wird. Auch könntest du die Farbtiefe ein wenig herunterstufen (unter Anzeige / Farbe)

  • Also ich habe jetzt ganz viel herumexperimentiert
    - Leitungsgeschwindigkeit gebe ich mit Parameter an, ich habe sie spasseshalber mal auf Analogmodem gesetzt und subjektiv eine Verbesserung festgestellt (obwohl mir das nach manpages nicht möglich erscheint)
    - Persistant Bitmap Caching ausgeschaltet (wegen dem Cache auf der SD-Karte), hat anscheinend keinen Einfluss
    - Farbtiefe auf dem Raspi sind 16 Bit. Gebe ich dem rdp 8 Bit vor, ist etwas aber nicht wirklich viel gewonnen (ich kann es leider nicht objektiv messen). Aber die Farbpalette schaut unmöglich aus.
    - Kompression auszuschalten (wegen der dafür erforderlichen Prozessorleistung) bringt keine sichbaren Vor- oder Nachteile
    - Dann habe ich den Raspi mal moderat übertaktet
    - Verbesserung scheint auch zu bringen, wenn ich RDP-Version 4 erzwinge. Aber die kann keine Sound redirection (vielleicht deshalb...).


    Durch eine Kombination dieser ganzen Sachen schaut es danach aus, als ob jetzt zumindest Tastatur und Maus stabil sind. Das wird sich erst mal im Langzeittest bestätigen müssen.


    Der Ton ist weiterhin abgehackt. Mit dem Windows-Tool hab ich sogar im Audacity herumeditieren können.
    Das hört sich für mich eher an, als ob (inzwischen) alles zeitgerecht ankommt aber nur scheibchenweise weiterverarbeitet wird.
    Der Raspi fährt im Regelfall bei höchstens 60% CPU-Last. An der Ecke sollten also kaum Engpässe sein.
    Wenn ich mal Zeit habe, werd ich andere RDP-Clients testen. Bis dahin bleibt der Ton aus :-X