Posts by marcel70

    Hello all,


    I am busy to reinstall my GO samples to make efficient use of my SSD space. This a good moment to optimize the "Initial MIDI Configuration" of GO for my setup.

    I found out that "Metronome Measure -" and "Metronome Measure +" have opposite effect as expected. This seems a small bug.

    Further I was looking for "Sequencer 000", "Sequencer -100" and "Sequencer +100" but unfortunately, these are missing in the list. Is it possible to add some lines to the config file myself? Or is an update of the GO software needed?


    Best regards,

    Marcel

    Ich benutze Debian 9 (Stretch) und ein Acer Touchscreen T232H. Manchmal als GO langere Zeit (? mehr als 60 minuten?) activ ist dann habe ich auch das Problem das ich mit 'ein Touch' kein Register ändern kann. Jedoch man kann die Register ändern mit 'eine Swipe' (start neben den Register, bewege der Finger über das Register). Wenn ich (nur!) GO stop und neu start dann ist das Problem gelöst.

    Hallo Oliver,


    Danke für die schönen Composit-Sets!
    Außer MenesterolExt habe ich sie alle ausprobiert auf mein Linux-Computer.
    Das geht sehr gut mit nur einer kleinen Anpassung:
    In oco150_AmeMod_v101.organ, ersetz alle "002058\pipesGreat" durch "002058\pipesgreat".


    Im Anhang mein Update v102.


    - entschuldige mich für mein Deutsch -


    Gruß,
    Marcel

    The locale output of 14.07 was including "my solution" (that is with LC_ALL="en_GB.utf8" added to /etc/environment).
    Today I removed the definition from /etc/environment, rebooted and listed again:


    Debian 9, output of "locale":
    locale: Cannot set LC_ALL to default locale: No such file or directory
    LANG=en_GB.UTF-8
    LANGUAGE=en_GB:en
    LC_CTYPE="en_GB.UTF-8"
    LC_NUMERIC="en_GB.UTF-8"
    LC_TIME="en_GB.UTF-8"
    LC_COLLATE="en_GB.UTF-8"
    LC_MONETARY=en_NL.UTF-8
    LC_MESSAGES="en_GB.UTF-8"
    LC_PAPER="en_GB.UTF-8"
    LC_NAME="en_GB.UTF-8"
    LC_ADDRESS="en_GB.UTF-8"
    LC_TELEPHONE="en_GB.UTF-8"
    LC_MEASUREMENT="en_GB.UTF-8"
    LC_IDENTIFICATION="en_GB.UTF-8"
    LC_ALL=


    The message "locale: Cannot set LC_ALL to ..." was NOT shown in Debian 8.


    I did also check starting GO. It does give again warning "Cannot set locale to language "English".
    After clicking OK, GO does start up normally.


    Regards,
    Marcel

    Hi Martin,


    Let me first state that I have little knowledge about the locale.
    So I didn't know the old Debian 8 settings. But, I do have a "shadow partition" on my computer that I sometimes use to test some software. And, because I did not upgrade it, it is still Debian 8.


    Debian 8, output of "locale":
    LANG=en_GB.UTF-8
    LANGUAGE=en_GB:en
    LC_CTYPE="en_GB.UTF-8"
    LC_NUMERIC="en_GB.UTF-8"
    LC_TIME="en_GB.UTF-8"
    LC_COLLATE="en_GB.UTF-8"
    LC_MONETARY="en_GB.UTF-8"
    LC_MESSAGES="en_GB.UTF-8"
    LC_PAPER="en_GB.UTF-8"
    LC_NAME="en_GB.UTF-8"
    LC_ADDRESS="en_GB.UTF-8"
    LC_TELEPHONE="en_GB.UTF-8"
    LC_MEASUREMENT="en_GB.UTF-8"
    LC_IDENTIFICATION="en_GB.UTF-8"
    LC_ALL=


    Debian 9, output of "locale":
    LANG=en_GB.UTF-8
    LANGUAGE=en_GB:en
    LC_CTYPE="en_GB.utf8"
    LC_NUMERIC="en_GB.utf8"
    LC_TIME="en_GB.utf8"
    LC_COLLATE="en_GB.utf8"
    LC_MONETARY="en_GB.utf8"
    LC_MESSAGES="en_GB.utf8"
    LC_PAPER="en_GB.utf8"
    LC_NAME="en_GB.utf8"
    LC_ADDRESS="en_GB.utf8"
    LC_TELEPHONE="en_GB.utf8"
    LC_MEASUREMENT="en_GB.utf8"
    LC_IDENTIFICATION="en_GB.utf8"
    LC_ALL=en_GB.utf8


    Debian 8, output of "locale -a":
    C
    C.UTF-8
    en_GB.utf8
    POSIX


    Debian 9, output of "locale -a":
    C
    C.UTF-8
    dutch
    en_GB
    en_GB.iso88591
    en_GB.utf8
    en_US
    en_US.iso88591
    en_US.utf8
    nl_NL
    nl_NL.iso88591
    nl_NL.utf8
    POSIX



    Interesting to see that in Debian 8 LC_ALL was empty too. And it did not gave the warnings. In Debian 9, I gave LC_ALL a value to solve the warning.
    Note: the list in locale -a is longer for Debian 9 because I added some languages in an attempt to solve the warnings. But it did not help.


    -----------


    I double checked installed packages.
    In Debian 8, grandorue, grandorgue-demo and grandorgue-resources are all: 0.3.1.2232-195.1
    In Debian 9, grandorue, grandorgue-demo and grandorgue-resources are all: 0.3.1.2232-144.1
    Note: after upgrading to Debian 9, I removed all GO packages and the reference to the repository. This makes it unlikely that I reinstalled files meant for Debian 8.


    Regards,
    Marcel

    Hi Martin, all,


    I upgraded my PC to Debian 9 yesterday. After that, I tried to upgrade GO, but without success. Then I completely removed GO from my computer and did a fresh install. This worked OK. :-)


    Starting the new version of GO gave me a warning "Cannot set locale to language "English".". I tried several solutions found on the internet. Adding LC_ALL="en_GB.utf8" to /etc/environment helped me to get rid of the warnings.
    (See https://ubuntuforums.org/showthread.php?t=1720356 )


    So GO is running fine now on Debian 9. :-organ:


    Regards,
    Marcel

    Hello all,


    I am using GO for a few years now. I like it very much.
    The software is installed on my Linux computer running Debian 8.


    Three weeks ago, the new stable Debian 9 was released. I would like to install it, but on
    http://download.opensuse.org/r…me:/e9925248:/grandorgue/
    there is only a GO-version for Debian 8.
    Did any GO-user upgrade his/hers computer to Debian 9?
    Does anyone know if a Debian 9 version of GO is coming soon?


    Note: I foresee dependency issues with packages libwxbase3.0-0 and libwxgtk3.0-0 because they are replaced by libwxbase3.0-0v5 and libwxgtk3.0-0v5 in Debian 9.


    Thanks for your help,
    Marcel