Unable to set desired samplerate

  • Hello everybody,


    I'm Jaap from the Netherlands and I'm using GO 1665 and a Focusrite 6 USB soundcard.
    Every time I start GO, I get a warningmessage with;
    Unable to set the desired samplerate
    Close all programs that a playing sound, using the device.


    Ii dont understand. GO is the only program with sounds I use


    Has anyone an idea to solve this problem?

  • What audio driver entry in GO are use using? This message is generated by your audio driver.
    A user of the sound card could the system (eg. it play a sound at startup and other events) or a background program.


    As a workaround, you could try changing the sample rate in the GO audio settings and/or try a different audio driver entry in GO.

  • Quote

    Original geschrieben von martin


    What audio driver entry in GO are use using? This message is generated by your audio driver.
    A user of the sound card could the system (eg. it play a sound at startup and other events) or a background program.


    As a workaround, you could try changing the sample rate in the GO audio settings and/or try a different audio driver entry in GO.


    In Grandorgue I use: Asio Saffire 6 USB.
    In Windows i turned allsounds off.
    I am not able to change the samplerate in GO.
    When I try another audio driver, I have no sound. :/

  • I do not have the Saffire 6 USB soundcard; i have an older model Focusrite Saffire using firewire.
    With the driver (for Windows) comes the Saffire Control program.
    This program allows to change the sample rate of the sound card.
    Perhaps you have a similar control program and could try to set the sample rate to the value of the samples you use in GO.


    Another possibility could be a conflict between the driver of your Saffire 6 USB and the chipset used in your PC.
    See http://global.focusrite.com/an…-devices-on-non-root-hubs for some info about this in the Focusrite knowledge base.


    Maybe all of the above is not relevant to your problem, in that case just neglect is.


    All the best.


    Erik.

  • Vielen dank for your support! (Both of you),


    After a though workaround I uninstalled and reinstalled Grandorgue, The Saffire soundcard and switched the connection between yj soundcard and computer. Now it works!
    But the specifications tell me that the Saffire is able to handle 96Khz samplerate, but if I try to adjust the samplerate in Grandorgue to 96 Khz (For the Dluga Kostljena-organ) it says that this samplerate is not supported by this device.
    If it doesnt support 96Khz, can I play the organ in another samplerate (48Khz) without distortion?
    Otherwise I have to sell my soundcard and buy a newer one......
    What do you think?


    And in my audio control panel (Focusrite), I only can adjust the buffer length and samplesize. No samplerate (?)


  • I have checked the characteristics of the .wav files used in the Dluga Kostljena-organ.
    This is the result:
    Audio
    Formaat : PCM
    Formaatinstellingen, Endianness : Little
    Formaatinstellingen, Sign : Signed
    Codec-ID : 1
    Duur : 12s 663ms
    Bitrate-modus : Constant
    Bitrate : 2 304 Kbps
    Kanaal(en) : 2 kanalen
    Samplerate : 48,0 KHz
    BitDepth/String : 24 bits
    Stroomgrootte : 3,48 MiB (100%)


    If you set the sample rate to 96 kHz while the samples are at 48kHz, you are expecting your sound card to resample each sample. I don't think that this will work.


    To check that your sound card supports 96 kHz, you will need an organ disposition with samples at 96 kHz.
    You can find several on the following website:
    https://sites.google.com/site/orgueatuyaux/Home
    Note that these dispositions have only a few notes per octave sampled; the missing ones are extrapolated from the real samples.


    As to what parameters the control program of your sound card allows to set, i cannot advise because i don't have the same sound card. If the manual does not clarify your question, perhaps an email to the Focusrite support team can.


    All the best.

  • Thank you very much Erik.


    So I dont have to worry about 96Khz. :-dance:
    It finally works now. I found out that Grandorgue didnńt see mij Focusrite when I used the USB 2.0 option in the installer.
    When I choose USB 1.0 , it works


    I've already send a mail to focusrite....
    Thanks a lot!

  • Quote

    If you set the sample rate to 96 kHz while the samples are at 48kHz, you are expecting your sound card to resample each sample. I don't think that this will work.


    GO will resample it - not the sound card driver. The GO output is always using the sample rate specified in the GO audio settings.

  • Quote

    I uninstalled and reinstalled Grandorgue


    Uninstalling/reinstalling GO is always a useless operation - user settings remain unchanged.


    To get rid of the user/organ settings, delete the GrandOrgue* Files in your profile directory.