Synchronität paralleler Audio-Interfaces

  • Hallo,


    ich habe neulich experimentiert mit Hauptwerk und parallelen Audio-Interfaces:
    - Frontkanäle über Asio4All an USB-DAC Anti-Mode 2.0
    - Rearkanäle über Asio4All interne Realtek-Soundkarte (Analogausgang).


    Das ganze funktionierte grundsätzlich erstaunlich gut, allerdings kam es reproduzierbar nach ca. 2 Minuten zu Störgeräuschen (ich denke, auf den Rear-Kanälen). Spielereien an den Buffereinstellungen haben nichts gebracht.


    Erste EInschätzung per Halbwissen. Interfaces laufen nicht synchron (ANti-Mode nach eigener Clock, interne Soundcarte nach Rechner).


    Nach einiger Bedenkzeit leuchtet mir das ganze allerdings nun doch nicht mehr ein:
    1. Warum kommt es bei unterschiedlichen Kanälen zu Störungen. Meine Erwartung wäre eher ein Asynchronität der SIgnale.
    2. Sollten zudem nicht durch das ständige Abspielen neuer Samples die Spuren immer nur für eine Samplelänge auseinanderlaufen können und dann wieder durch Tastenanschlag neu synchron abgespielt werden?


    Fazit: Mir fehlt das genaue Wissen, um genau zu Verstehen, ob nun wirklich die Synchronisierung das Problem ist oder ggf. die Baustelle wo anders liegt. Weiss jemand mehr?


    Viele Grüße
    Gerd

  • Hallo Gerd,


    helfen kann ich Dir bei Deinem Problem zwar nicht, mir ist allerdings unklar, wie Du mit dem ASIO4All Treiber zwei unterschiedliche Soundkarten betreiben kannst! Ich habe auch schon damit experimentiert, bekam aber immer den Fehlerhinweis, dass nur ein ASIO Treiber geladen werden kann!


    Gruß Wolfram

  • Hallo Wolfram,


    das ist interessanterweise gar kein Problem. Man kann zwar nur einen Asio-Treiber gleichzeitig laden, jedoch kannst du in dem einen Asio4All-Kontrollkästchen problemlos mehrere Interfaces aktivieren und diese dann in Hauptwerk auch einzeln zuweisen.
    Das funktioniert problemlos - zumindest für zwei Minuten...


    Viele Grüße
    Gerd

  • Hallo Gerd,


    sehr interessant was Du da berichtest. Ich hatte vor Jahren derlei Versuche aufgegeben, weil es dann auch pauschal hieß, dass man mit Hauptwerk nicht zwei Soundkarten über ASIO verwenden könne. Der Grund ist mir bis heute aber auch unklar geblieben. Ohne ASIO meine ich, hätte es bei mir schon geklappt mit Soundkarte + Onboard-Sound. Allerdings bin ich eher wieder von Mehrkanaligkeit etwas abgekommen und inzwischen wieder Stereoliebhaber :D Gelegentlich nutze ich aber noch meine 8.1-Kanal-Abstrahlung, allerdings eben nur über eine einzelne Soundkarte (M-Audio Delta1010).


    Insofern kann ich jetzt auch nicht wirklich tiefgründig weiterhelfen. Ich werde aber bei nächster Gelegenheit ins Auge fassen es mal wieder mit zwei ASIO-Interfaces auszuprobieren.


    Gruß Michael

  • Quote

    Original geschrieben von martin


    ...
    Mit 2 ASIO Treibern wird das etwas schwierig :-)


    Nochmal um Missverständnisse zu vermeiden:


    Ich nutze nur einen Asio-Treiber (gleichzeitig). Asio4All kann aber mehrere Audiointerfaces ansprechen.


    Viele Grüße
    Gerd