Fehlermeldung beim Starten einer Orgel

  • Hallo zusammen :)


    Erstmal vorweg, da ich neu bin hoffe ich nicht allzu großen Blödsinn zu schreiben ... Aber auf den ersten Blick scheint mein konkretes Problem noch keiner formuliert zu haben, deshalb frag ich einfach mal ;)


    Ich hab mir das Sample-Set der Siedlar-Orgel in Krakau von Piotr Gabowski geladen, und entpackt, aber irgendwie mag es mich nicht. Wenn ich das .organ file starten will, öffnet sich GrandOrgue und spuckt mir folgende Fehlermeldung aus:


    ---------------------------
    Ladefehler
    ---------------------------
    Werteüberschreitung in Abschnitt 'Manual001' Eintrag 'NumberOfStops': 112
    ---------------------------
    OK
    ---------------------------


    Machen tut das Programm dann nix mehr.



    Warum? Was mach ich falsch?


    Ich hoffe ihr könnt mir helfen :)


    Liebe Grüße
    DerSchmied

  • Hallo und willkommen im Forum,


    vermutlich ist das eine veraltete GrandOrgue Version.
    Ich habe das aktuelle Set eben nochmal geladen und beide verfügbaren .organ Dateien funktionieren einwandfrei.
    Meine verwendete GrandOrgue Version dabei ist die v0.3.2093 und der PC läuft mit Linux 64-Bit.


    Sollte es auch mit aktuellem GrandOrgue nicht laufen, dann wäre noch gut zu wissen, auf welchem Computer mit welchem Betriebssystem das ganze läuft.


    Gruß Michael

  • Bei die aktuellste Version von GO (gestern.!?!) , habe ich Fehlers. Ursache: convolutie-Reverb.
    javascript:;


    Ubuntu 14.04 AMD 4Gb Speicher.


    GrandOrgue
    Sample rate : 44100, Samples: 128 /, und 24 Bits, Speicher: 3701, Cache: Automatic


    Audio : PA (usb device): 17 ms



    Nach laden von eine Sampleset, manchmal bei 1ste Start, oder nach Veränderung von Sampleset (nach ein/zwei/drei Mal) , schließt GO ohne ein ERROR. (Die übrige Zeit war nur: 0 sec.)
    Auch mit ein Orgel mit ein STOP und ein Pipe attack (!).



    GO START mit "TerminalWindow", erscheint wenn etwas schiefgeht eine Fehlermeldung: "Segmentation fault".


    Verwendung von Reverb geht gut, wenn Sie Reverb einschalten nach Laden. Das kann leider nich, Ich verwende die Orgel ohne Display, nur mit MIDI-Signale, und Reverb hat keine Midi-Signaleingang.
    Spielen mit der Orgel geht gut: keine Fehlers.


    Ich finde keine Berichte über das gleiche.



    Gruß Rein

  • Hast du GO für die richtige Version deiner Distribution in Verwendung? Welche GO Version ist es genau (dpkg -l | grep grandorgue)?


    Bitte ansonsten:

    Code
    1. sudo apt-get install gdb


    Dann:

    Code
    1. gdb /usr/bin/GrandOrgue
    2. run


    Jetzt bring GO zum Absturz. Dann gib ein:

    Code
    1. info threads


    Dann gib für jede Threadnummer ein:

    Code
    1. thread <99>
    2. bt


    Lass mir bitte den Output zukommen.

  • Martin,


    Die 1ste mal fehlt bei mir release 1991. Auch Release 2093 fehlt. Deshalb die Frage..


    (Update mit : "Grab binary packages directly" Beim Update mit Release.key habe ich ein Netzwerkfehler)





    Ich habe info threads gesucht. Sehen die Anhang.



    Im Folgenden sein keine zusätzlichen Informationen gegeben:


    ------------------------
    Dann gib für jede Threadnummer ein:


    thread <99>
    bt
    ---------------------------


    Vielen Dank für Ihre Aufmerksamkeit, hoffentlich könnt Ihr Hilfe.



    Gruß Rein

  • Der Aufruf der thread-Kommandos ist OK - es fehlt aber leider nach jeden "thread 99" Kommando noch ein "bt" Kommando. So fehlt einfach der Kontext, was genau los ist.


    PS: Du kannst die Ergebnisse auch als Text-Datei liefern.