Erste Gehversuche :)

  • Hallo Leute :)


    ich hab mir nun auch endlich einen PC zugelegt und angefangen Orgel zuspielen.


    Ich hab das Problem, dass meine Latenz recht hoch ist, und ich nich weiß, welche Einstellungen ich vornehmen soll.


    Wenn es dazu schon einen Thread gibt: Sorry, hab ihn nicht gefunden.


    Ich spiel an einer Viscount Vivace 50Dlx mit Midi an meinem PC angeschlossen. Specs:


    Prozessor: Intel i5 6500 (3,2Ghz | 3,6 Ghz)
    Grafikkarte: Nvidia Geforce GTX 970 (4gb)
    HDD: 2tb
    SSD 250GB
    RAM: 16gb
    Betriebssystem: Windows10


    Dazu hab ich mir eine Externe Soundkarte gekauft: Sound Blaster X-Fi HD (https://de.creative.com/p/soun…-digital-music-premium-hd) und Beyerdynamics DT 770Pro



    In den Threads hab ich oft von Wasapi / WDkms gelesen, aber die ich finde in meinen GO Settings nicht bei meiner externen Soundkarte. Die Latenz ist so bei 50ms, was aber zum Spielen zu viel ist...


    Außerdem hab ich oft einen Knisternden Sound, der dann nach einer Zeit wieder verschwindet.



    Ich hoffe mir kann jemand von euch helfen! :/


    LG! 8-)

  • Hallo NanoAddo,
    erst mal herzlich willkommen bei den GO'lern!
    Das man mal was im Forum nicht findet, kann schon passieren (du weist, dass es hier ein Volltextsuche gibt, das Icon mit der kleinen Lupe ?). Aber das mit der Soundkarteneinstellung und dem Windows-Knistern sind wohl die großen Hürden auf dem Weg zu einer zufriedenstellenden GO-Installation.


    Daher hier in aller Kürze ein paar Hinweise, woran es bei dir liegen könnte:
    Die Friesach (tolles Set nebenbei bemerkt), geht mit allen Features gerade so in 16 GB rein (habe genauso viel RAM wie du), Die Gefahr ist hier aber schon, dass Windows doch anfängt zu swappen und dann knistert es eben. Also, entweder vielleicht nur mit 16-bit laden, dann ist das Set deutlich kleiner oder an den reichhaltigen Release-Samples (zu deutsch: "Nachhall laden") Verzicht üben.
    Wenn es daran nicht liegt, tippe ich auf die Stromspareinstellungen. Die sind per default in Windows10 sehr eifrig gesetzt, aber lästig zum Orgelspielen. Daher, das Profil für max. Leistung wählen, damit Platten und Adapter nicht in Stromsparmodus versetzt werden (allein die Hintergrundprozesse, die da die Timer überwachen, können schon stören). Für mehr Details (und falls du mit Englisch gut klar kommst, ist viel aus den Hauptwerk FAQ rauszukriegen, gilt im Grunde das meiste auch für GO: https://www.hauptwerk.com/faq/technical/#10).
    Nun zur Latenz: Nach meiner Erfahrung ist das mit den Treibern heute nicht mehr so das große Problem (wenn ich an die vielen Postings zum Thema ASIO4ALL denke). Wichtig ist aber, dass du einen Wert vorgibst, d.h. im Fenster "Audio Ausgabe" bei den Eigenschaften zu deinem Sound-Device die erwartete Latenz einstellst (50 ist m.W. der Default, ich habe 25 gesetzt und kann damit gut leben), Das muss auch zu den Werten Sample-Rate (sollte denke ich auf 48000 stehen) und "Samples pro Buffer" passen (ich komme mit 512 zurecht).


    So, das mal als kleine Starthilfe. Gibt wie gesagt User/Entwickler mit deutlich mehr Fachkenntnis als ich, die auch schon viel zu den Themen geschrieben haben. Vielleicht probierst du zunächst mal meine Tipps aus, wenn's dann nicht reicht, melde dich wieder hier im Forum. Dann dürfen die Experten ran...
    Gruß, Oliver

  • Hallo und willkommen im Forum.


    Bezüglich Deiner Latenz: hast Du als Audio Gerät Windows WASAPI (PA) Lautsprecher (USB Sound Blaster HD ) oder
    WDM_KS Speakers (HD Audio Lautsprecher) ausgewählt?


    Über Eigenschaften lässt sich dann die Latenz noch anpassen.


    Bezüglich Knistern: Im Menü MIDI& Audio Einstellungen lässt sich die Samplingrate und die Samples pro Puffer einstellen. Die Samplingrate sollte dem Set entsprechen, also ca 44100 betragen. Über die Puffergröße lässt sich die Latenz, aber auch die Stabilität regeln. Kleine Puffergrößen ergaben kurze Latenzen, aber die Instabilität wächst und umgekehrt.
    Also hier mal die Puiffergrößen höher setzen (ca 250).


    LG Wolfram

  • Nach zu ergänzen: MME ist die am schlechtesten geeignete Audio API. Die ist nur die letzte Ausweg. Da sind Latenz-Beschwerden keine Überraschung.
    PS: Die GO Hilfe enthält auch noch ein paar Hinweise zu den Audio APIs.

  • Vielen Dank für die vielen Antworten!


    Bezüglich Deiner Latenz: hast Du als Audio Gerät Windows WASAPI (PA) Lautsprecher (USB Sound Blaster HD ) oder
    WDM_KS Speakers (HD Audio Lautsprecher) ausgewählt?


    Momentan habe WASAPI (PA) Lautsprecher (USB Sound Blaster HD ) ausgewählt. (Da ist auch mein Kopfhörer angeschlossen)
    ich kann irgendwie bei WDM_KS meine externe Soundkarte gar nicht auswählen...



    2 Probleme habe ich noch:


    - Ich hab meistens ca. nach einer Minute Spielzeit ein komisches Knistern, das sich dann auch wieder legt, aber wirklich stört...


    - Die Latenz bekomme ich nicht unter 25ms, auch wenn ich in dem Eingabefeld z.B. 10ms eingebe.
    Hat das irgendetwas mit meiner externen Soundkarte zu tun?



    LG an alle Helfer :)

  • Quote


    - Die Latenz bekomme ich nicht unter 25ms, auch wenn ich in dem Eingabefeld z.B. 10ms eingebe.
    Hat das irgendetwas mit meiner externen Soundkarte zu tun?


    Rechne dir mal aus, wie lange das Abspielen von "Samples pro Buffer" Samples bei deiner Samplerate dauert.

  • Ich sehe das genauso. Die Samples pro Buffer sind mit 512 zu hoch eingestellt. Da nützt auch das Schrauben an der Latenz bei Eigenschaften nichts. Deshalb auch das Knistern.


    Bei meinem Rechner habe ich die Samples pro Buffer auf 125 eingestellt. Allerdings benutze ich eine interne PCI Karte mit ASIO Treibern, da sieht das schon wieder anders aus. Also: Samples pro Buffer mal auf 250 stellen und schauen, was passiert.

  • Jetzt muss ich mich wohl als Neuling outen :/


    Rechne dir mal aus, wie lange das Abspielen von "Samples pro Buffer" Samples bei deiner Samplerate dauert.


    Wie mache ich das denn?


    LG

  • Ohne sehr große Ahnung davon zu haben, schätze ich mal, wenn du eine Samplerate von z.B. 44100 hast, sind das dann 44100 Samples pro Sekunde. Wenn du einen Buffer von 512 Samples pro Buffer hast, dauert die Übertragung des Buffers dann 512/44100 Sekunden, also rund 12msec. Damit kann es bei einer Samplerate von z.B. 44100 und 512 Samples/Buffer nie auf 10msec kommen. Also lieber kleinere Buffergröße nehmen, vielleicht 125 Samples/Bufferm, oder Samplerate hochdrehen (ist das eine Sampleseteigenschaft? Ist es sinnvoller, über 48000 hinauszugehen? Keine Ahnung...).
    LG Olaf

  • Mir ist die Jagd nach ultrakurzen Latenzen eh nicht geheuer. Bei uns in der Kirche steht der Orgeltisch ca. 10m von den Pfeifen entfernt. Wenn ich mich nicht verrechnet habe, wobei ich das Ansprechverhalten der Pfeifen noch nicht mal berücksichtige, braucht der Schall schon ca. 30 msec, bis er bei mir ist. Ich bin daher ganz froh, dass ich ein ähnliches Ansprechverhalten auch bei mir daheim habe. Außerdem habe ich in den ODF schon gesehen, dass mit dem Parameter TrackerDelay das Ansprechverhalten vom Sample Set Ersteller bewusst verlängert wurde.


    Schlimmer ist das Knacksen, und wenn ich drüber nachdenke, habe ich auch seit den letzten Windows10 Updates öfter mal ein Knacksen bei Sample Sets, die zuvor einwandfrei liefen, ganz ohne Parameter-Änderungen in GO oder an der HW. Steht vielleicht im Zusammenhang mit den spectre/meltdown patches.


    Solange ich nur für mich dudele, halb so wild, aber bei Aufnahmen/Zuhörern natürlich nicht so dolle.

  • Hallo :)


    Vielen Dank für die vielen Antworten!


    Ich bin gerade wieder am Ausprobieren und habe folgende Sachen festgestellt:


    Wenn ich Versuche die Sample Rate versuche auf etwas anderes zu stellen als 48000 bekomme ich eine Fehlermeldung (Anhang)


    Außerdem habe ich (Bei 48000 Rate) die Samples pro Buffer auf Werte zwischen 50 und 250 eingestellt, die Latenz bleibt aber (bei angeforderten 15ms) trotzdem bei 25ms


    Bei den meisten OrgelSamples ist das auch ok, aber bei der von Lipiny, die langsam anspricht stört mich das doch ganz schön.



    Zu der Sache mit der Berechnung. Gibt es da eine Vorschrift oder Einstellungen pro Orgel und Sampleset oder sozusagen "für einen PC / Soundkarte"
    Wäre es da nicht sinnvoll eine Excel-Tabelle zu formatieren, die die Werte für die Einstellungen ausgibt?



    LG und einen schönen Feiertag!


    Joel

  • Also zu den Sample-Raten der Sample-sets:


    Die samplesets stehen ja zunächst nur in EINER samplerate zur Verfügung. Diese in Echtzeit mit einer anderen Rate wiedergeben zu wollen, wäre immens rechenaufwändig und sinnlos. Jede Abweichung der Wiedergabe-rate von der Orginalsamplerate verschlechtert die Wiedergabequalität. Ohne Umrechnung wäre einfach die Tonhöhe zu hoch oder zu tief.... Also wenn das set in 48kHz zur Verfügung steht es in 44,1kHz wiedergeben zu wollen ist Quark. Andersrum ebenso....


    Viel mir nur so auf, hoffe, es trägt zur Klärung bei.


    Also lieber an Bufferanzahl und Buffergröße schrauben.


    Liebe Grüße


  • Ist ja witzig, dass heute gleich zwei Fragen zur Lipiny im Forum sind...


    Die Lipiny ist in der Tat imho eines der "langsamsten" Sets, speziell die durchschlagende Trompete braucht "ewig" bis sie anspricht und ist daher für Trompeten-Solos kaum brauchbar (dafür aber toll als Ensemblestimme). Hier ist, evtl. um die langsame Trompete nicht zu sehr gegen die anderen Register abfallen zulassen, in vielen Ranks der ODF-Parameter "Pipe999TrackerDelay=" gesetzt, teilweise bis Wert von 7 (z.B. HW-Prinzipal 8'). Bin nicht 100% ob das ms oder irgendein Faktor ist, aber es macht die Ansprache einfach länger.
    Falls dich speziell die Lipiny also zu sehr stört, könntest du versuchen überall den TrackerDelay auf 0 setzen, oder du findest doch noch in deinem GO-Setup eine andere Einstellung die die Latenz weiter drückt (hast du eigentlich mal - nur zum Vergleich - es mit der internen Soundkarte versucht, wie da die Latenz ist?).
    Oder du weichst auf ein anderes Set aus. Ich spiele auch gern von PG die Skrzatusz(Sauer) oder die Szczecinek (Völkner), sind ja beide aus der gleichen Epoche und haben ebenfalls schöne deutsch-romantische Klangfarben.


    Viel Erfolg!

  • Hallo und vielen Dank für die Tipps!


    Ich habe inzwischen mit Windows Direct Sound(PA) und 256 Samples pro Buffer bei 48khz (Piotr Grabowski hat mir diesen Wert gesagt) eine annehmbare Latenz von 15ms.


    Jedoch hab ich immernoch offene Fragen :??:


    1) Ich habe immernoch ein Knacken / eher Knistern auf meinen Kopfhörern. Es kommt und geht, nervt aber auf jeden Fall. CPU und Ram sind weit von der Obergrenze entfernt und sollten also noch Reserven haben.


    2) Die Aussage von Martin verstehe ich nicht. Ich hab einiges zu Samplerate etc. gelesen, verstehe aber folgendes nicht: "Und auch nicht vergessen: Während ein Audio-Buffer abgespielt wird, muss der Zweite schon parallel berechnet werden. Also mal 2 nicht vergessen. Alles was einen Wert darunter anzeigt, lügt dich an."


    3) In den Orgeleigenschaften ist der Eintrag "Tracker", bei dem im ms angegeben wird, mit wieviel Verzögerung der Ton abgespielt wird. Ich möchte nicht jeden einzelnen Wert auf 0 setzen, aber wenn ich z.B. für ein Register die 0 eingebe, wird das nicht für die einzelnen Töne übernommen...


    Ich hoffe ihr könnt mir helfen, denn mit den Samplesets und GO zu üben macht richtig Spaß :)


    Euch allen eine gute Zeit!